Skip to content

Installation

Installing Fondant#

Install Fondant by running:

pip install fondant

Fondant also includes extra dependencies for specific runners, storage integrations and publishing components to registries.

Runner specific dependencies#

pip install fondant[kfp]
pip install fondant[Vertex]
pip install fondant[SageMaker]

Storage integration dependencies#

pip install fondant[gcp]
pip install fondant[aws]
pip install fondant[azure]

Publishing components dependencies#

For publishing components to registries:

pip install fondant[docker]

Check out the guide on publishing components to registries.

Runner specific dependencies#

Docker installation#

To execute pipelines locally, you must have Docker compose and Python >=3.8 installed on your system. We only support Docker compose V2 and above. If you have an older version of Docker compose, please upgrade to the latest version as described in the Docker compose migration doc.

IMPORTANT

For Apple M1/M2 ship users:

  • There is no support for linux/arm64 based images (yet). linux/amd64 images will be used by default.

  • In Docker Desktop Dashboards’ Settings -> Features in development, make sure to uncheck Use containerid for pulling and storing images.

IMPORTANT

For Windows users:

  • We recommend installing and running docker on WSL. Check out this guide for more info on the installation.
    .